Our partner solarisBank AG is experiencing booking-problems
Incident Report for Kontist
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 22, 2019 - 21:28 CET
Investigating
We are currently investigating this issue.
Posted 4 months ago. Mar 22, 2019 - 20:19 CET